Scheduled for May 30, 2025 at 5:30 PM – 6:00 PM
Affects
Internet Broadcast Stream
Under maintenance from 5:30 PM to 6:00 PM
Completed
May 30, 2025 at 6:00 PMCompleted
May 30, 2025 at 6:00 PMMaintenance has completed successfully
In progress
May 30, 2025 at 5:30 PMIn progress
May 30, 2025 at 5:30 PMMaintenance is now in progress
Planned
May 30, 2025 at 5:30 PMPlanned
May 30, 2025 at 5:30 PMSoftware updates necessitate a restart of the systems responsible for our Internet Streaming. This will take the Stream down for a few minutes. The broadcasts at 91.7FM in Grand Rapids, 90.5FM in Bemidji and 89.9FM in Brainerd should be unaffected by this process.